Publication Delay for 4pm London Prints: All Index Families

Incident Report for CF Benchmarks

Resolved

This incident has been resolved.
Posted Aug 22, 2026 - 20:55 BST

Investigating

The Administrator is currently working on resolving delayed publication of the London publication of indices in the following index families:

CME CF Single Asset Series
CF Single Asset Series
CF Capitalization Series
CF Classification Series
CME CF Volatility Series
CF Staking Series

Questions or queries regarding this process and decision should be directed to info@cfbenchmarks.com.

Complaints regarding this process and decision may be made confidentially by writing to complaints@cfbenchmarks.com.
Posted Aug 22, 2026 - 17:00 BST