[CF Bitcoin Interest Rate Curve] - Publication Delay
Incident Report for CF Benchmarks
Resolved
This incident has been resolved.
Posted Apr 06, 2024 - 16:57 BST
Identified
The Administrator is currently working on resolving delayed publication of the Index.

Full Index Name: CF Bitcoin Interest Rate Curve

Ticker: BIRC

Date: 06-April-2024

Delayed Publication (INVESTIGATING)

The Administrator is currently working on resolving delayed publication of the [Index/Indices]. If the [Index/Indices] cannot be calculated for a given Calculation Day before 23:59:59 London Time, then the index value[s] for this Calculation Day will be given by the corresponding index value[s] on the previous Calculation Day.

Questions or queries regarding this process and decision should be directed to info@cfbenchmarks.com.

Complaints regarding this process and decision may be made confidentially by writing to complaints@cfbenchmarks.com.
Posted Apr 06, 2024 - 16:56 BST