CF Bitcoin Interest Rate Curve Publication Delay

Incident Report for CF Benchmarks

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 16:57 BST

Investigating

Full Index Name: CF Bitcoin Interest Rate Curve

Ticker: BIRC

Date & Time: 11-07-2025

The Administrator is investigating delayed calculation and publication of the Index [OR IMPACTED INDICES] and published the Index [OR IMPACTED INDICES] on 11-07-2025 before 23:59:59 London Time.

Questions or queries regarding this process and decision should be directed to info@cfbenchmarks.com.

Complaints regarding this process and decision may be made confidentially by writing to complaints@cfbenchmarks.com.
Posted Jul 11, 2025 - 16:31 BST