CALCULATION FAILURE of Yooldo Games - Dollar Market Price

Incident Report for CF Benchmarks

Resolved

This incident has been resolved.
Posted May 29, 2026 - 11:55 BST

Identified

The Issue has been identified as diverging mid prices across the constituent exchanges of Yooldo Games - Dollar Market Price, such that all constituent exchanges breach the 25% Potentially Erroneous Data Parameter.
Posted May 29, 2026 - 08:31 BST

Investigating

The Administrator reports the occurrence of a Calculation Failure for the index listed below.

Full Index Name: Yooldo Games - Dollar Market Price

Ticker: U_ESPORTSUSD_RTI

Date: 29-May-2026

The occurrence of any Index Price calculation failure is reported to an applicable Oversight Organ.

Questions or queries regarding this process and decision should be directed to info@cfbenchmarks.com.

Any complaints regarding this process and decision can be made confidentially by writing to complaints@cfbenchmarks.com.
Posted May 29, 2026 - 07:22 BST