Delay in Calculating u_in_methusd

Incident Report for CF Benchmarks

Resolved

This incident has been resolved.
Posted Feb 16, 2026 - 22:39 GMT

Investigating

Ticker: u_in_methusd

Date: 16 FEB 2026

Delayed Publication (INVESTIGATING)

Questions or queries regarding this process and decision should be directed to info@cfbenchmarks.com.

Complaints regarding this process and decision may be made confidentially by writing to complaints@cfbenchmarks.com.
Posted Feb 16, 2026 - 22:17 GMT