Currently investigating multiple Xstock indicies

Incident Report for CF Benchmarks

Resolved

This incident has been resolved.
Posted May 25, 2026 - 17:08 BST

Investigating

We are aware of an issue currently affecting multiple of our Xstock indicies. We are investigating the issue.
Posted May 25, 2026 - 16:38 BST