Delay in Calculating of CF Rolling CME Bitcoin Futures, CF Rolling CME Ether Futures, and CF Rolling CME Bitcoin Ether Basket Futures Index

Incident Report for CF Benchmarks

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 22:43 BST

Investigating

The Administrator is currently working on resolving delayed publication of the CF Rolling CME Bitcoin Futures, CF Rolling CME Ether Futures, and CF Rolling CME Bitcoin Ether Basket Futures Index.

Full Index Name: CF Rolling CME Bitcoin Futures, CF Rolling CME Ether Futures, and CF Rolling CME Bitcoin Ether Basket Futures Index

Date: 01 June 2026

Delayed Publication (INVESTIGATING)

Questions or queries regarding this process and decision should be directed to info@cfbenchmarks.com.

Complaints regarding this process and decision may be made confidentially by writing to complaints@cfbenchmarks.com.
Posted Jun 01, 2026 - 21:36 BST