BIRC Publication Delay
Incident Report for CF Benchmarks
Resolved
BIRC index is now published.
Posted Feb 24, 2024 - 18:31 GMT
Investigating
The Administrator is currently working on resolving delayed publication of the Index.

Full Index Name: Bitcoin Interest Rate

Ticker: BIRC

Date: 24-Feb-2024

Delayed Publication (INVESTIGATING)

The Administrator is currently working on resolving delayed publication of the Index. If the Index cannot be calculated for a given Calculation Day before 23:59:59 London Time, then the index value for this Calculation Day will be given by the index value on the previous Calculation Day.

Questions or queries regarding this process and decision should be directed to info@cfbenchmarks.com.

Complaints regarding this process and decision may be made confidentially by writing to complaints@cfbenchmarks.com.
Posted Feb 24, 2024 - 17:57 GMT