Restatement & Republishing of Wisdomtree Indicies May 16th 2025

Incident Report for CF Benchmarks

Resolved

This incident has been resolved.
Posted May 16, 2025 - 19:15 BST

Identified

Ticker: WisdomTree Mega, WisdomTree Market, WisdomTree Altcoin (Reference Rates and Real Time Indexes)

Date: 16 May 2025

In accordance with the Administrator’s Restatement & Republishing Rules the Index Settlement Rate for 16 May 2025 Calculation Day was required to be recalculated and republished with correct weights.


The occurrence of any Restatement & Republishing events is reported to an applicable Oversight Organ.

Questions or queries regarding this process and decision should be directed to info@cfbenchmarks.com.

Any complaints regarding this process and decision can be made confidentially by writing to complaints@cfbenchmarks.com.
No components were marked as affected by this incident.
Posted May 16, 2025 - 17:51 BST